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Chapter 1
Introduction

CodeNet® allows hospital personnel to efficiently and accurately manage resuscita-
tion information. It includes two software programs, CodeNet Writer and CodeNet
Central.

CodeNet Writer is a Windows Mobile program that allows you to:
* Log real-time code events.
* Collect medical personnel’s signatures.

» Upload resuscitation records directly from ZOLL Medical Corporation defibrilla-
tors.

» Attach those records to code events in CodeNet Writer.
You can then upload the code event and resuscitation information stored in CodeNet

Writer to a workstation running CodeNet Central, a Windows program that allows
you to:

* Collect resuscitation data.

* Add information and annotations to an event.

» View the ECG in its entirety, or in magnified, playback, or analysis mode.
* Route cases for code audits.

* Generate case and aggregate reports.

* Synchronize defibrillator event times and other interventions documented in
CodeNet Writer to the workstation to provide consistent and accurate times.

* Submit resuscitation data to the National Registry of Cardiopulmonary Resuscita-
tion (NRCPR), using the NRCPR interface in CodeNet Central.

The NRCPR is the in-hospital resuscitation event registry sponsored by the American
Heart Association (AHA). For more information about the NRCPR and the support it
provides for practice management and quality improvement, go to
http://www.nrcpr.org/.

The CodeNet Administrator’s Guide provides information on the optional tools avail-
able in CodeNet:

* Completing highlighted fields in CodeNet Central and CodeNet Writer
* Customizing tab views

*  Documenting HIPAA disclosure information
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Performing code audits

Submitting cases to NRCPR

Hints for Using this Book

Interface elements, command names, and menu names are shown in bold.

When you should press a combination of keys at the same time, they are shown
joined with a Plus (+) symbol, for example, Alt+n.

If you should type something, it is displayed in a monospaced font.
All procedures are numbered:

1. Even a one-step procedure.

Get the Latest Revision of this Book

The latest revision of the PDF version of this book is automatically transferred to your
system whenever you perform an upgrade.

You can also download the latest PDF version of this book at any time:

1.

Go to www.zoll.com.

2. Click Documentation.

3. Click CodeNet Event Data Management.
4.
5

. Click the document you want to view.

Under CodeNet Resources, click Literature.
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Chapter 2
Overview

There are typically two types of users for CodeNet, a documenter (submitter) and an
administrator (code auditor). The submitter documents the code in CodeNet Writer and
uploads the defibrillator record to the mobile device. The mobile device is then connected
to the CodeNet Central workstation and the data is moved to the central share folder on the
network. The submitter views the case on the workstation and enters missing data. Later,
the code auditor reviews all cases and may add additional data, if necessary. Cases stored
in the central share folder are organized behind the scenes into unsubmitted and submitted
folders.

CodeNet uses Windows user groups to control access to the desktop application, thereby

allowing only CodeNet users to start the application and controlling functionality by user

type.

» ZDUsers. Only members of this group can start CodeNet Central. All CodeNet users
must be a member of this group.

* ZDSubmitters. Only members of this group are restricted from opening cases outside
of the unsubmitted folder. Users that will be responsible for documenting codes should
be a member of this group.

* ZDAdmins. Only members of this group can access Tools > Options. Users that will
be responsible for reviewing cases in the Submitted and Unsubmitted folders should
be a member of this group.

CodeNet 4.0 Administrator’s Guide
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Chapter 3

Configuring Tab Views

In CodeNet Central, 14 tabs are displayed to the user by default (15 tabs are displayed if
you are using NRCPR). This number of tabs can be overwhelming, especially if you need
only enter data on four of those tabs. CodeNet Central provides the ability to specify
which tabs are displayed to the user. The configuration of the tabs to display is stored for
each user separately and can be set in CodeNet Central by choosing Tools > Options. For
detailed instructions, see the CodeNet Getting Started Guide. Because you would have to
log into Windows as each user to set the view configuration, this may not be the most effi-
cient way to accomplish this task.

There is a more efficient way to accomplish this task when all your users need the same
tab view. Contact your deployment specialist about the tabs that you would like to omit
from view. A custom license.cfg file will be created to define the view you want. In this
solution, the settings apply to all users of that workstation. If you limit the number of tabs
to be displayed, this workstation should be used by CodeNet submitters only; CodeNet
administrators should have access to all 15 tabs and will need to run CodeNet on a sepa-
rate machine.

Note: The tabs for which the submitters will be responsible vary by hospital.

CodeNet 4.0 Administrator’s Guide
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Chapter 4

HIPAA

The Health Insurance Portability and Accountability Act (HIPAA) is a federal
law passed in 1996 that allows group coverage to be ported from one carrier to
another and includes a privacy rule for protecting personal health information

(PHI).

HIPAA Disclosure Log

CodeNet Central automatically records events in which a patient’s PHI is
revealed. There are five such events recorded in the HIPAA disclosure log, as

described in Table 1.

Table 1. HIPAA Disclosure Log Events

Event Description

Access The user opened a case. The event includes the
name of the user who opened the case and the
time the case was opened.

Export The user exported a case. The event includes the

name of the user who exported the case, the time
the case was exported, and the location to which
the file was exported.

NRCPR Validation

The user validated a case for NRCPR. The event
includes the name of the user who validated the
case and the time the case was validated.

Adjust defibrillator start time

The user adjusted the defibrillator start time. The
event includes the name of the user who adjusted
the start time, the time the start time was adjusted,
and the original and new start times.

Document

The user added a note to the HIPAA disclosure log.

The event includes the name of the user who
added the note, the time the note was added, and
the text of the note.

Note: For the document event to take place, the user must manually enter a
HIPAA Disclosure Note available in the Edit menu. The event is then auto-
matically added to the HIPAA disclosure log.

CodeNet 4.0 Administrator’s Guide
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Printing the HIPAA Disclosure Log

The HIPAA Disclosure log is available as a report from the Print menu. To access this

report, choose File > Print > Case > HIPPA Disclosure (Figure 1).

Figure 1. HIPAA Disclosure Report

HIPAA Disclosure
2006-11-28 17:28:04

CPR number: 000124

Report Date: 2007-01-22 21:47:30
Prepared by CodelNet (TM) Central

Patient

Daoe, Jane

MR=: 011103

Sex:

Race:

Date of birth: 1904-01-01
Height: 63

Weight: 110 |bs

HIPAA Disclosure Notes

Time Usar Details

2007-01-22 txshmaore User viewsd case.

21:35:24 620

2007-01-22 txshmaore User exported case to CrYDotuments
21:36:15 734 and

[ | |Settings'zashmore'Deskrop'\2007_01_2
2007-01-22 tashmore User transferred data to local NRCPR
21:37:15 732 datzbase for validation.

2007-01-22 tashmaore User changed defbrillator power on
21:44:47 T14 time: from 2006-11-28 16:28:04 wm

_ | |2006-11-28 17:28:04

2007-01-22 tasnmore User enterad note: Printed Code Record
21:47:04 56 report
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Chapter 5

Code Audit

CodeNet Central provides mechanisms to help ensure that data entered for a case is
complete. For example, fields highlighted in red let the user know that required infor-
mation is missing. The code audit process tracks incomplete cases to their comple-
tion.

Highlighted fields

You must complete the following red highlighted fields on the Code Record tab
before you can submit a case for code audit. If you do not complete these fields,
you will be prompted to do so before the code audit submission will be
successful.

+ Patient ID/MR Number

* Last Name

* Event Type

+ Patient Type

» Physician Leader

* Recorder

The Code Quality tab also requires data. You can either select No code quality issues
or enter the required information.

Events on the Code Log tab will be displayed in red text if either data is missing
or the data needs to be transcribed. There are two scenarios in which an event
may be marked blue to indicate a potential issue:

* The defibrillator event does not include the defibrillator type or biphasic
answered.

* The defibrillator event was manually recorded in CodeNet Writer and automati-
cally recorded by the defibrillator, thereby resulting in two identical events instead
of one unique event.

In the first scenario, you may not have the necessary information to complete the
fields. If you leave the event incomplete, you can still submit the case for code audit.

In the second scenario, CodeNet Central marks the event blue to indicate a possible
duplicate shock. You can still submit a blue event for code audit. In the case where

CodeNet 4.0 Administrator’s Guide
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defibrillator data exists, CodeNet Central interprets manually-recorded shocks as
duplicate shocks and hides them from the user. However, if no defibrillator data
exists, the software displays the manually-recorded shocks in black text, indicating
that they are unique events. You can display the hidden shocks, using the Show All
Hidden Shocks button. When you click this button, CodeNet Central displays the pos-
sible duplicate shocks in blue text, and displays Duplicate? in the Comments column.
You can accept or re-hide the duplicate shocks. If you accept them, using the Accept
Duplicate Shock button, CodeNet Central changes the text that represents the shock
from blue to black, thereby marking the shock as a unique event. If you hide them,
using the Hide All Duplicate Shocks button, they will again be hidden from view and
be ignored.

Note: Defibrillator recorded shock events will always be considered unique
events, be visible, and appear in black text.

Code Audit Process

The code audit process involves four statuses: Unsubmitted, Submitted, Rejected,
and Accepted, each of which can be searched on individually. The process may
include:

» Reviewing the work of a code documenter.
* Viewing, adding, or editing the information submitted by the code documenter.

* Viewing, adding, or editing information on tabs on which the code documenter
does not work.

» Accepting the case, or rejecting it and returning it to the code documenter for
additional work.

Note: The code audit features work in conjunction with the Windows user
groups. See Chapter 2. With the Windows groups in place, the submitter can
submit the case only. The Administrator can submit, reject, or accept cases.

To submit, accept, or reject a case:

1. Choose Tools > Code Audit, and then choose Submit, Accept, or Reject from the
CodeNet Central main window. A popup window opens, prompting you to enter
comments about the case.

2. Enter comments, such as an explanation as to why a case is being submitted with
missing information or why a case is being rejected.

CodeNet 4.0 Administrator’s Guide
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3. If you want to send an e-mail, go to Step 4. If you do not want to send an email,
click OK to complete the action (submit, accept, or reject the code record).

4. If you want to send an e-mail to indicate that a change has occurred in the code
audit status, click the Notify via email checkbox and then click OK to complete
the action (submit, accept, or reject the code record). A new message of the
installed MAPI-compliant e-mail application opens, as shown in Figure 2.

Figure 2. Code Record E-mail Window
54 Code record submitied by HStaveley at 2006-12-18 11:29:51 178 - Message - Microsof... (2 |[B[X]
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Cei

Subject: Code record submitted by Hftaveley at 2006-12-18 11:29:51 178

[Patient: Doe. Comment:

«0»|<l

2

[ = 4] : |+

In the body of the e-mail, CodeNet Central includes your comments and the name
of the patient. The Subject: field contains the submitter’s name and time of the
audit status transition. The To: field is blank.

If you want the To: field to always contain the e-mail address of the code auditor,
choose Tools > Options > Code Audit. In the Default email address for audit
notifications: field, enter the e-mail address of the person to which you want to
send the messages. When you configure an e-mail address, the Notify via email
checkbox in the popup window will always be selected. If you do not configure an
e-mail address, the Notify via email check box is not selected, thereby making it
optional.

5. Click Send to send the e-mail.

CodeNet 4.0 Administrator’s Guide
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You can display the history of the code audit from the Code Audit History tab on the
CodeNet Central main window. The history information includes the date and time of
the action, the action performed (Rejected, Submitted, or Accepted), the name of the

user who performed the action, and any comments that the user entered in the popup

window.

CodeNet 4.0 Administrator’s Guide
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Chapter 6

NRCPR

CodeNet Central allows you to submit resuscitation data to the National Registry of
Cardiopulmonary Resuscitation (NRCPR), using the NRCPR interface from the
CodeNet Central main menu. Hospitals that participate in NRCPR receive an NRCPR
software CD. The NRCPR will train one or more users from those hospitals on how to
use the NRCPR software and participate in the NRCPR program. NRCPR provides a
local database file in which the records are stored until the hospitals submit them to
the NRCPR. Some hospitals choose to submit their NRCPR records once every three
months; others may choose to submit their records more frequently, such as once a
month.

The NRCPR software is available through your ZOLL Sales Representative. For
more information on NRCPR, go to http://www.nrcpr.org.

Enabling the NRCPR Software

NRCPR has its own application that is installed on the workstation. NRCPR is
responsible for assigning a facility ID, authorized users, and pointing the software to
the correct database file.

Once this is completed, CodeNet can be configured to interface with the NRCPR
database file.

1. In CodeNet Central, choose Tools > Options > NRCPR.

2. Enable NRCPR.

3. The default installation folder for NRCPR is C:\Program Files\NRCPR. If the path
to NRCPR is not shown, click Change and then browse to and select the NRCPR
software installation folder.

4. Add authorized users, including information such as their Windows network IDs,
their NRCPR IDs, and passwords, as configured in the NRCPR application.

CodeNet Central is now ready to add cases to the NRCPR local database. Since not
every case will meet the criteria for NRCPR, hospitals must review each case individ-
ually and decide whether to submit it to the NRCPR.

CodeNet 4.0 Administrator’s Guide
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Submitting Cases to the NRCPR

CodeNet Central stores data in a combination of XML and binary format, in files with
the extension .zol. These files typically get stored in a shared folder that you have set
up on the network. When you select a file to be submitted to the NRCPR, a flag is set
in the .zol file and the software enables Validate for NRCPR. The button is red to
indicate that validation is not yet successful. When the case is validated, a call is made
to the nrcprapi.dll, which is the same dll used by NRCPR’s standalone application.
This dll validates the case for meeting NRCPR criteria. The data from the .zol file is
copied into the NRCPR local database at this time. A check for possible duplicates is
concurrently made.

The NRCPR criteria rules are described in the NRCPR Operational Definitions manu-
als. To access these manuals, choose Tools > NRCPR > NRCPR Operational Defi-
nitions. Three records must pass validation: Admit, Cardiopulmonary, and
Respiratory (if applicable). When a validation issue is found, the edit checks returned
by the dll are displayed in CodeNet on the NRCPR Validation tab. After the issues
have been resolved, the case is validated again. The data is updated in the NRCPR
database and validation will either be successful, or more issues will be displayed on
the NRCPR Validation tab. After the case has been validated, CodeNet Central dis-
plays a green heart and the NRCPR database marks the three records as closed. The
case is now ready to be submitted to NRCPR.

Submitting cases to NRCPR involves transferring closed cases from the local data-
base to the national NRCPR database. This function is performed from within the
NRCPR application. When the process has been completed, the cases are marked in
the local database as sent. When you open a sent case in CodeNet Central, the heart
icon has a blue checkmark.

Transferring Data from CodeNet Central to the
Local NRCPR Database

Data entered on every tab in CodeNet Central must meet the NRCPR criteria in order
for the case to validate successfully. The data collected on the Code Log tab repre-
sents a chronological record of the events in the case; the data on this tab can also be
used as a reference to complete the fields on the remaining tabs. The shocks repre-
sented on this tab are the only events that get pulled directly into the NRCPR data-
base.

CodeNet 4.0 Administrator’s Guide
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Viewing Cases in the NRCPR Application that
Originated in CodeNet Central

When a case is validated (successfully or not) for the first time in CodeNet Central, it
is then added to the local NRCPR database. At this time, it can be viewed in the
NRCPR application. All data fields regarding Cardiopulmonary, Respiratory, and
Admission should match what was entered in CodeNet Central. Any reports run from
within the NRCPR application will be accurate and up-to-date because the NRCPR
application and CodeNet Central share the same local NRCPR database.

CodeNet 4.0 Administrator’s Guide
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Chapter 7

Technical and Sales Support

For customers in the United States, contact ZOLL Medical Corporation at the following
address, telephone numbers, e-mail address, fax number, or URL if you have questions
about using the CodeNet software or want information about software sales, upgrades, and
support contracts:

ZOLL Medical Corporation

269 Mill Road

Chelmsford, MA 01824-4105 USA

Telephone: toll free (800) 348-9011 or (978) 421-9655
E-mail: TechSupport@zoll.com

Fax: (978) 421-0015

Web: www.zoll.com

For customers in all other locations, either send e-mail to TechSupport@zoll.com or con-
tact your nearest authorized local ZOLL representative. International offices: http://
www.zoll.com/contact.htm.
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